Jump to content
kummitus

New Community Updater - Tutorial and download

Recommended Posts

2 minutes ago, kummitus said:

Windows 7 users! Make sure your Operating System is up to date, otherwise updater might not work!

Okay, my problem was Windows wasn't up to date.
For whatever reason the automatic updates were disabled.
A big thanks to Kummitus!

  • Like 1

Share this post


Link to post
Share on other sites
On 1/4/2019 at 4:50 PM, kummitus said:

Windows 7 users! Make sure your Operating System is up to date, otherwise updater might not work!

I run updater just fine in win 7

Newest KB pack installed in 2016. The rest is 2011-2014

div microsoft visual c++ 20XX redistributable

Microsoft NET Framework 4.6.1 as 4.7.2 made div. utilities & software crash when starting up for me, Only way to reverse to 4.6.1 was with a cloned backup of win 7 as uninstall would not fix the crashing.

 

Btw. I also have the very small CMP icon in taskbar 🙂

o9EGiGz.png

Edited by Spieler4

Share this post


Link to post
Share on other sites

I don't know exactly what patch, but some does bring the Windows buildin certificate store up to date, that for example the Updater and Internet Explorer rely on to validate websites for legitimacy. Firefox for example has its own so is not directly affected by it.

Share this post


Link to post
Share on other sites

I downloaded it again from that link, same error:
 

(Sorry, I already tried yesterday to solve it by my own, but I couldn't).

 

image.thumb.png.e17a957b49b8ebf8788a5d243063815d.png

  

 

 

Share this post


Link to post
Share on other sites

I used the installer from the link of the first post...

After installed where is the .exe of the installer?

I just don't get it...

I am installing the new version but is installing the old one?   😂

 

Sorry, it must be annoying for you all... but I am actually trying... :D 

Share this post


Link to post
Share on other sites

Oh lol... I was confused, sorry.

I thought that I had to:

1- Install the updater

2- Execute updater

Thanks very much...

I thought I was doing it wrong because I didn't have the Pacific maps...

Share this post


Link to post
Share on other sites

Hi

The FH2CommunityUpdater is the old one, that has come with the unofficial standalone for quite some time, but not anymore. You can uninstall that one now.

 

The updater does not "install" itself anywhere, but is run independently whenever necessary from the same .exe.

Share this post


Link to post
Share on other sites

I just downloaded the map update for the campaign, and I noticed that the updater shows the text "Please wait while FH2 Community Installer is being installed". This is a bit confusing. The first time I tried it I also thought the .exe installed the new updater, not the map update.

Maybe you'll change that in the next update.

 

cmp-installer.jpg

Share this post


Link to post
Share on other sites

Yeeh, in many ways it can be a bit confusing, thats been thought of, its just the annoyance with false AV warnings thats pushing us back from doing updates on the software itself more often

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We also recommend reading our Privacy Policy and Guidelines.